HELP !!! Error setting up IWebCF

Jul 12, 2010 at 7:20 PM

I have issues getting the set up of IWebCF running.  I have DNN 5.4.1 and installed just installed IWebCF 2.0.  My DNN website is in C:\Inetpub\wwwroot\DNN\ and I see the folder for C:\Inetpub\wwwroot\DNN\DesktopModules\IWebCF.  I don't rebuild the site and just browse to http://localhost/DNN/DesktopModules/IWebCF/CoreService.svc//IWebUserManager, I get an error message It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.  I guess this is b/c inside C:\Inetpub\wwwroot\DNN\DesktopModules\IWebCF folder, there's a web.config file.  Do I have to set this folder up as virtual directory in IIS?  I tried but it didn't work either.

Another issue is when I tried to build CoreService.svc page inside DNN website, I'm getting an error 'ServiceHostFactory' is ambiguous in the namespace 'System.ServiceModel.Activation'. 

Please point me to the right direction with this. 

Also, when I get this set up running properly, I hope that I can browse to http://localhost/DNN/DesktopModules/IWebCF/CoreService.svc//IWebUserManager method and see a test page??? or I can use the IWebCF example project and change the reference to point correctly to my DNN WCF and it should work right?

Thanks.

 

 
Coordinator
Jul 12, 2010 at 7:25 PM
Ian is currently on vacation so there may be a delay in him getting back to you. The only thing I know is that you should not need to configure a virtual directory. As to the other error, IWeb was never tested to work under ASP.NET 4.0 so that could be an issue, you may want to run your DNN site under ASP.NET 3.5 to see if that fixes any issues.
Aug 17, 2010 at 5:06 AM

It seems that ktnguyen and me are looking everywhere for the answer. We posted almost the same question here:
http://www.dotnetnuke.com/Community/Forums/tabid/795/forumid/111/threadid/248501/scope/posts/Default.aspx See KNguyen and Rad - me (second page) replies.

I assume both of us are using asp.net 4 solution.
Since .NET clients: IWeb_Core_Connector_CF.exe, IWebCFExplorer.exe, SVNControlIWebCF.exe IWebCF clients all have end point similar like this:
<endpoint address="http://<dnnsiteurl>/DesktopModules/IWebCF/CoreService.svc/IWebFileTransferManager">
I assume that we shouldn't create an application or virtual folder pointing to <c:\..path to Website Folder>\DesktopModules/IWebCF
because we want this configuration: <serviceHostingEnvironment aspNetCompatibilityEnabled="true"  to work (to interact with DNN environment).

However I still don't know what to do with web.confing inside IWebCF folder to pass compilation of DNN. I installed the source version of IWebCF which compiles under WSP project type.
Tx,
Rad

Coordinator
Aug 17, 2010 at 2:14 PM
Sorry ktnguyen after vacation I got slammed with a lot of catch up work and totally lost track of your post. So it appears we have a couple of things going on here, all of which are probably linked to trying to run this module under ASP.Net 4. There were a few changes to WCF in version 4 that could produce these types of errors. For example, 'ServiceHostFactory' is ambiguous in the namespace 'System.ServiceModel.Activation'. is probably do to a change in the WCF api in version 4. More than likely the module will have to be modified to work under the new API. With that said, here are some answers to your collective questions that should help get you further down the path. 1. No, you do not need to create a virtual directory or any additional IIS configuration for this module to work. 2. Yes when the module is working you should be able to browse the endpoint address and see the WCF service test page. 3. Under ASP.Net 3.5 there should be no needed modifications to the web.config. Any changes required now are due to differences in 3.5 and 4. I am not sure what these are, as I have not worked with pure WCF 4 or researched changes to web.config declaration changes. My GUESS on #3 is maybe try removing this section: <system.web> <!--<httpRuntime maxRequestLength="2097151" />--> <webServices> </webServices> <webControls clientScriptsLocation="/aspnet_client/{0}/{1}/" /> <httpRuntime executionTimeout="1500" maxRequestLength="512000" /> </system.web> Again you are both attempting something that I have not tested or developed the module for. It may require you to make some modfications to the code base and\or configuration to get this to work. If you get it to work and want to share the solution let me know and I may incorporate it in the code base so others can use it as well. Otherwise, if I come up with extra time I may work on getting this module ASP.Net 4 compatibile; however, it does not appear that it would be anytime soon. Sorry I cannot offer more help, but hopefully this information will point you in the right direction.
Sep 8, 2011 at 10:52 AM

I know this is quite an old discussion, but for the benefit of anyone else who comes across this issue, I just wanted to confirm that taking itlackey's advice and removing all un-needed sections of the web.config, leaving only the System.ServiceModel section does fix this issue.